Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 15, 2026 - 18:00 CEST
Scheduled
We'll increase the resources (cpu & ram) of the main server. It should take one hour.
Posted Jun 04, 2026 - 18:24 CEST
This scheduled maintenance affected: Suite Prod - SLA, Suite Prod - Frontend, Suite Prod - Authenticator, Suite Prod - Classify, Suite Prod - Extract, and Suite Prod - Workflows.